jueves, 24 de septiembre de 2015

Contar caracteres dentro de una celda de Excel

Me encontré en días pasados con esta nueva forma de ver cómo es que funciona Excel.

Supongamos que tiene una lista de elementos en una celda de Excel separados por una coma y quieres saber la cantidad de elementos que están indicados en esa celda (Casa, perro, gato, loro, animales, vaso, excel.)

O tienes una serie de elementos en una celda (en donde se repiten algunos) y quieres saber cuantos elementos hay de uno en particular (perro, loro, animal, vaso, perro, casa, excel, perro, nube.).

Solución: contar el número de comas que están separando estos elementos, o contar el elemento repetido que buscas. (perro)

La función es la siguiente: La lista de elementos están en la celda A1

Ejemplo 1: Casa, perro, gato, loro, animales, vaso, excel.

=SUMA(LARGO(A1)-LARGO(SUSTITUIR(A1;",";"")))/LARGO(",")+1

Ejemplo 2: perro, loro, animal, vaso, perro, casa, excel, perro, nube.

=SUMA(LARGO(A3)-LARGO(SUSTITUIR(A3;"perro";"")))/LARGO("perro")


Lo interesante de estas formulas, es que realmente no se ejecuta todo lo que se indica en ella. Veamos:

Para el primer ejemplo, la función SUSTITUIR lo que hace es cambiar las "," por nada (""), pero realmente esta función no se ejecuta, pues el resultado en la celda donde esta la formula no es el texto modificado. Luego con la función LARGO se compara el largo del texto inicial con el nuevo en donde se quitaron las "," y se divide en el largo del texto "," para calcular las veces que se repite este texto.

Esta forma de ver como funciona Excel, nos abre un abanico de opciones.


No hay comentarios:

Publicar un comentario en la entrada

Related Posts Plugin for WordPress, Blogger...